A WordPress és a PHP verziók kapcsolata, ez most rendkívül aktuális téma minden WordPress oldal tulajdonos számára

Először is nézzük az alapokat:

PHP egy elterjedt, nyílt forráskódú szerver-oldali programozási nyelv.
A WordPress a szerver oldalon PHP-t használ, melyből átlagosan 4 – 5 verzió közül (5.6, 7.0, 7.1, 7.2 és eseteként már 7.3 is) lehet válogatni a szolgáltatóknál.

Jelen bejegyzésünkben ennek fogunk most utána menni, ezt megelőzően azonban két fontos információt meg szeretnék osztani!

Webhelyed biztonsága érdekében mindig használj friss bővítményeket és sablont, hiszen az elavult kódok biztonsági réseket rejtenek/rejthetnek!
A bővítmény utolsó frissítésének idejét annak letöltési oldalán, jobb oldalt ellenőrizheted!
Soha ne használj olyan bővítményt, mely már 2 éve nem kapott frissítést!

A bővítmény adatai

A bővítmény vagy sablon futtatásához szükséges minimális PHP verziót is mindig ellenőrizd (pl.: PHP Version: 5.3 or higher azaz 5.3 vagy magasabb verzió)!

A tesztek ugyan azon a hardveren (azaz vason 🙂 ) lettek elvégezve az alábbi szoftverekkel és verziókkal.

• WordPress 5.0,
• WooCommerce 3.5.2,
• Twenty Nineteen

A mérések eredményei táblázatban, kérés/másodperc értékben lettek feltüntetve, ahol a nagyobb érték számít jobbnak.

Teszteljünk!

PHP 5.6

A WordPress futásához jelenleg minimálisan szükséges PHP verziónak az 5.6 van definiálva, mely átlagban az alapértelmezett beállítás is a szolgáltatóknál.
Ez két okból is szomorú.

  • Egyrészt ehhez a verzióhoz már nincs hivatalos támogatás 2019 január óta,
  • Másrészt jelentősen lassabb kódfutást biztosít a jelenleg még támogatott verziókkal ellentétben!
WordPress 5.0 91,64 req/sec
WordPress 5.0 + WooCommerce 3.5.2 24,74 req/sec

A fentiek fényében kifejezetten cikinek tartom az alábbi ábrán megjelenő adatokat. A mai napon (2019.07.10.) aktívan wp-t futtató szervereken használt PHP verziók.

A WordPress-t futtató aktív PHP verziók aránya

Sokszor hallottam, hogy a wp nem biztonságos.

Az előbbi ábra láttán el is tudom képzelni, azonban a nem megfelelő szerver konfiguráció (46,2% elavult PHP verzióval működik) vagy a karbantartatlan kód nem a WordPress hibája!

Vessünk hát az alábbiakban egy pillantást a verziók összehasonlítására!

PHP 7.0

2019 január eleje óta már ez a verzió sem kap hivatalos támogatást!

WordPress 5.0 206,71 req/sec
WordPress 5.0 + WooCommerce 3.5.2 56,94 req/sec

PHP 7.1

2016 év végén debütált és 2018 decemberében szűnt meg az aktív támogatása. Biztonsági frissítéseket még 2019 év végéig fog kapni. A karbantartott wp bővítmények és sablonok már kompatibilisek ezzel a verzióval, így ennél kisebb PHP verzió futtatása semmiképpen sem javallott.

WordPress 5.0 210,98 req/sec
WordPress 5.0 + WooCommerce 3.5.2 57,00 req/sec

PHP 7.2

2017 decemberében adták ki, 2019 év végén zárul az aktív támogatása, azonban biztonsági frissítéseket 2020 decemberig kapni fog. A rendesen karbantartott sablonok és bővítmények már erre a verzióra is fel vannak készítve, ahogyan a wp is! Ha nincs olyan kiegészítőd vagy sablonod, mely ne támogatná ezt a verziót, akkor ajánlott ezt használnod!

WordPress 5.0 229,18 req/sec
WordPress 5.0 + WooCommerce 3.5.2 63,10 req/sec

PHP 7.3

2018 év végén adták ki, jelenleg ez a legfrissebb verzió. Aktív támogatással rendelkezik és már a WordPress is fel lett rá készítve. Ugyanakkor még nem támogatja minden bővítmény és sablon!

Fontos megjegyeznem, hogy bár ez a verzió a legfrissebb és a tesztek szerint a leggyorsabb is, üzemeltetői szemmel használatát még nem javaslom! Jelen esetben az, hogy ez a legfrissebb PHP verzió, a legnagyobb „hibája” is. Informatikai rendszerek üzemeltetésénél mindig a szoftverek legfrissebb verziójának futtatását javaslom.

Ugyanakkor, mivel jelenleg is több PHP verzió rendelkezik aktív támogatással, nem javaslom a legmagasabb verziószámú kiadás használatát! Ennek az az oka, hogy mivel viszonylag friss kiadásról beszélünk több felfedezetlen vagy javítatlan hibát tartalmazhat a többi verzióhoz képest.

WordPress 5.0 253.20 req/sec
WordPress 5.0 + WooCommerce 3.5.2 68.87 req/sec

Konklúzió – lehet, hogy Te is bajban vagy?

Kitűnően látszik, hogy a PHP sebessége az egyes verziók kiadásával folyamatosan növekszik (5.6 és 7.3 között már nagyjából 3x-os), így érdemes mindig az újabbat használni.

Az én ajánlásom a legfrissebb verzió -1, ami jelenleg a 7.2-es. Az új honlapoknál a szerveren használandó verziót mindig ennek megfelelően állítom be, valamint a meglévőket a megfelelő frissítések és ellenőrzések után erre állítom át.

A fenti sebességtesztek együttesen, diagramokon:

WordPress 5.0 Benchmark
WordPress 5.0 + WooCOmmerce 3.5.2 kombó Benchmark

Kételyed van, hogy a Te oldalad esetleg nem elég friss? Ne várd meg, míg oldalad bajba kerül. Vedd fel velünk a kapcsolatot az alábbi form-on keresztül és segítünk egy biztonságos, friss, SEO barát oldal létrehozásában.

Bodor Ádám
Programozó

Vedd fel velem a kapcsolatot az alábbi űrlap segítségével.

7 + 2 =

Források:

https://www.php.net/supported-versions.php
https://kinsta.com/blog/php-benchmarks/